ScriptX and IE7

ScriptX has long provided control over printing in Internet Explorer, and this continues with Internet Explorer 7. With each major release of Internet Explorer there has been a new - and always fully backwards-compatible - release of ScriptX in order to maintain compatibility and to provide additional feaures.

This release is no different - ScriptX v6.3 or later is required when working with IE7 on Windows XP (SP2), Windows Vista or Windows 7, so both publishers - licensed, and free -  and individual users will have to update.

ScriptX users' update

Please go to the user upgrade to current version page.

Publishers' update

For your ScriptX-enabled content to work with IE7 it is mandatory that - if you are working with any earlier build of ScriptX to v6.3 - you now update to the new version (7,6,0,10 ) of the ScriptX binaries.

Note: ScriptX v6.4 and later no longer support Windows 9x/NT. For maintenance support of these operating systems, please see ScriptX Win9x/NT Maintainance Mode Binaries.

We strongly recommend you download the latest ScriptX Client Resource kit to obtain the latest binaries and deployment instructions. Licensees should log on to the My MeadCo portal to obtain the Licensee Resource Kit.

For convenience, the important bits are available below.



To deploy this new version of, download it and copy it over *every* existing copy of on your servers.

Then update the Codebase versioning on ALL your ScriptX-enabled pages to read:


Also please make sure that the 'Codebase' attributes on ALL your documents are 'pointing' to the location of this new copy of

codebase="http://xxxxxxxxxx/,6,0,10 >"


To perform a manual install, or to pre-install ScriptX on client machines, please download the ScriptX setup application then run the application on each client machine. The installer must be run by a local administrator; on Windows Vista or later with UAC enabled, the Elevation dialog will be displayed during installation.